Suchindex neu erstellen - Forum langsam!

Dieses Thema im Forum "Fragen & Probleme" wurde erstellt von André, 10 April 2015.

  1. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Durch einen Datenbankfehler musste ich den kompletten Suchindex des Forums löschen.
    Diesen lasse ich gerade neu erstellen, 5.000 Beiträge pro Durchgang. Das Forum durchsucht nun quasi alle Beiträge und speichert sie als Index neu in der Datenbank ab.

    Das führt dazu dass der Server aktuell stark belastet wird und das Aufrufen einer Seite ein bissel länger dauern kann. Das bitte ich zu entschuldigen!

    Aktuell sind bereits 788.000 Beiträge eingelesen. Sollte also nicht mehr ganz so lange dauern bis es wieder normal läuft. :top:
     
    Holgy gefällt das.
  2. Anzeige für Gäste


    um diese Anzeige auszublenden!.
  3. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Hat alles funktioniert. Suchindex ist neu erstellt, Suche funktioniert wieder, Datenbankfehler behoben und Forum wieder schnell. :top:
     
    Holgy, Chris1983 und Oldschool gefällt das.
  4. Chris1983

    Chris1983 Well-Known Member

    Beiträge:
    10.420
    Likes:
    1.402
    Ha... Herr Capo! Wollte vorhin nen Link zu Marin bringen und hab danach gesucht. Jetzt gerade auch nochmal. Nix is! Und ich könnt schwören, dass es zu Marin mal einen Thread gab.

    Den haste also schön gelöscht gelassen!! Schlingel! :D ;)
     
    André gefällt das.
  5. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Bei mir kommt da jede Menge Auswahl:

    marin.jpg

    Vermutlich hast Du nur in einem bestimmten Unter-Forum gesucht. Wenn du z.b. im MG Forum bist und dann nach Marin suchst dann ist ein Haken drin und voreingestellt, dass du nur dieses Unterforum durchsuchst.

    Entweder zuerst oben auf Forum-Home dann auf die Suche, oder den Haken manuel entfernen, dann wird das komplette Forum durchsucht, und dann findest Du auch Themen von dem Zwockel. ;)
     
    Chris1983 gefällt das.
  6. Chris1983

    Chris1983 Well-Known Member

    Beiträge:
    10.420
    Likes:
    1.402
    jaja, erwischt worden und schnell geändert! :baseball:
     
    André gefällt das.
  7. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Das Forum war zwischen 05 und 7 Uhr nicht erreichbar. Der Suchindex ist wieder gecrashed. Diesen lasse ich gerade neu erstellen, deshalb ist auch der Server gerade etwas langsam. 450.000 beiträge sind schon durch. Denke in ner Stunde sollte das erledigt sein.
     
  8. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    So, Suchindex ist neu erstellt und somit sollte das Forum wieder normal laufen. Ich mache mir allerdings gerade Gedanken, das in Zukunft zu vermeiden. Es gibt eine verbesserte Suchfunktion die anders aufgebaut ist. Diese ist beoi größeren Foren schneller und genauer. Wird empfohlen ab 1 Million Beiträgen. Falls wir das umstellen wird es auch noch schnell ein Upgrade der Forensoftware (Optik bleibt gleich, aber technisch gibt es paar neue Funktionen und weniger bugs) geben. Ich kläre das gerade alles ab und werde dann nochmal informieren.
     
  9. huelin

    huelin Quite clear, no doubt, somehow

    Beiträge:
    28.999
    Likes:
    3.749
    Hört sich gut an, Chef. Du machst das schon... *Schleimmodus aus* ;)
     
    André gefällt das.
  10. Chris1983

    Chris1983 Well-Known Member

    Beiträge:
    10.420
    Likes:
    1.402
    Bah, doppelt ekelig wenn schon Zecken schleimen! :p
     
    huelin gefällt das.
  11. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Gerade gab es wieder einen Ausfall. Unser Hoster hat den Server beim letzten Ausfall aber in ein engeres Monitoring gesetzt und ich erhoffe mir hier nun endlich Erkentnisse über die eigentliche Ursache. Die sollte nämlich erst gefunden werden bevor wir die Forenversion upgraden.
     
  12. Rupert

    Rupert Je suis soleil

    Beiträge:
    36.118
    Likes:
    3.165
    Egal nach was ich suche, die Suche liefert keine Treffer mehr; bei keinem Stichwort; die Suchanfrage nach "Tschechien" sollte beispielsweise Andrés Thread zur U21 EM ausspucken, tut sie aber nicht: Keine Treffer
     
    André gefällt das.
  13. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Stimmt. Lasse morgen vormittag den Suchindex neu erstellen dann sollte es wieder passen.
     
  14. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Läuft gerade, könnte aktuell zu Verzögerungen des Servers führen.
     
  15. André

    André Foren-Capo Administrator

    Beiträge:
    43.793
    Likes:
    2.728
    Suche sollte nun wieder funktionieren. Bei ca. 90% gab es aber einen Abbruch und einen Servertimeout. Ich bin gerade mit dem Hoisdter in Kontakt. Es kann also sein, dass ihr über die Suche z.b. den ein oder anderen Thread nicht findet. Aber ca. 90% sollten nun im Index drin sein.

    Vermutlich muss der Hoster die Limits erhöhen und ich lasse das Script dann später nochmal komplett durchlaufen.